heating problem on corsa c [Archive] - CORSA-C|UK

: heating problem on corsa c



dannydawson94
22-04-2013, 12:34
Oright boys and girls, I know you've all heard it before about heating but don't really don't know what's happening as its my first car and don't really know much... My corsa c is only blowing freezing cold air and no warm air what so ever... My engine gets up to temperature and sits around 85 when driving and I had a quick feel at the two pipes that go into the bulkhead and they both felt warm to me so I was just wondering what else there is what I could possibly try, was thinking fuses? Or maybe coolant/air lock

Thanks people, Danny.

Pugh125k
22-04-2013, 12:36
prob air lock

have a go at doing this and see if there is any change
http://www.corsa-c.co.uk/forum/showthread.php?358622-How-to-flush-the-heater-matrix-from-the-engine-bay

andy-v
22-04-2013, 12:45
ya thought a mod might of moved this to the correct part of the forum :ninja:

Pugh125k
22-04-2013, 12:49
ya thought a mod might of moved this to the correct part of the forum :ninja:

tbh i never looked at where it is i just read what they have to say :lol:

will have to look from now on

have moved it

andy-v
22-04-2013, 12:54
tbh i never looked at where it is i just read what they have to say :lol:

will have to look from now on

have moved it

:doublethumbs:

Tangeriney
22-04-2013, 13:13
Blocked heater matrix :ninja:

dannydawson94
22-04-2013, 17:52
but it hought it was only blocked when one of the pipes that go into the bulkhead is cold? just felt mine now after a 20minute drive and they are both hot

pinkpig
22-04-2013, 17:56
but it hought it was only blocked when one of the pipes that go into the bulkhead is cold? just felt mine now after a 20minute drive and they are both hot

Im not sure if its block off when the thermostat is closed or not but either way once the car is warmed up and both pipe are hot and there is no air comming out then your heater matrix is blocked.
Take both hoses off and connect hose pips to both of them, plug on hose pipe into the main tap and flush it, switch them over until its nice a clear water flowing.
Then start it up, bleed or top up the resivour if it needs it and go for a 5 min drive, they should come hotter much sooner.!

Tangeriney
22-04-2013, 20:33
It could well be that the water is flowing, but the channels in there are blocked. It's a free fix, you may as well try it, because it seems the most logical explaination when you're getting temperature etc..

Mine threw out luke warm air for ages until i got a new heater matrix, been happy ever since.

pinkpig
22-04-2013, 20:38
When there is no movement in the water it will become stagnant and if left will just corrode and leak over time.