Indicator relay problem

User Tag List

+ Reply to Thread
Results 1 to 8 of 8

Thread: Indicator relay problem

  1. #1

    Join Date
    26-09-2011
    Location
    Cardiff
    Age
    21
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Indicator relay problem

    I got a Vauxhall Corsa C 2004 and whenever it rains I can't indicator left at all. The whole one side of the car doesn't flash and on the instrument cluster it flashes really fast like a bulb is out

  2. Remove Advertisements
    Corsa-C.co.uk
    Advertisements
     

  3. #2

    Join Date
    03-06-2012
    Age
    31
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi there I have a Corsa c 04 as well and mine does the same thing randomly even when it's not raining. Sometimes it goes a week or more without doing it and works fine but then randomly it does the same as your. I will eventually try to resolve it I hope someone can give us a few pointers on here.

  4. #3
    Wales Organiser mike0491's Avatar
    Join Date
    24-08-2009
    Location
    South Walesssss
    Age
    23
    Posts
    46,571
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    So replace the relay?
    South Wales Regional Organiser

  5. #4

    Join Date
    03-06-2012
    Age
    31
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    well apparently it can be the relay or indicator stock mike0491 so have you actually changed the relay and it worked or are you guessing ??
    to be fair bradburys happens when its raining so his could be that water is getting in through the box the relay is in somehow but mine happens randomly
    raining or not.
    Last edited by devils sidekick; 23-06-2012 at 21:22.

  6. #5
    Wales Organiser mike0491's Avatar
    Join Date
    24-08-2009
    Location
    South Walesssss
    Age
    23
    Posts
    46,571
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Faulty stalk normally results in the indicator staying on when turning etc
    Relay normally involves not operating correctly i.e not working on a side/both sides, flashing incorrectly etc.

    Not hard to work that out, and i have no idea on the price of relays but the stalk is cheap as chips to replace.
    South Wales Regional Organiser

  7. #6

    Join Date
    03-06-2012
    Age
    31
    Posts
    50
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok cheers for reply sounds like it's the relay then. do you know if it is separate relays for each side or one for both ?

  8. #7

    Join Date
    01-12-2009
    Location
    Sheffield
    Age
    24
    Posts
    9,255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mike0491 View Post
    So replace the relay?
    This, I had to replace mine and I think there's only 1

  9. #8
    Wales Organiser mike0491's Avatar
    Join Date
    24-08-2009
    Location
    South Walesssss
    Age
    23
    Posts
    46,571
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    http://www.ebay.co.uk/sch/i.html?_nk...at=0&_from=R40 couple on ebay atm, one new and 3 used
    South Wales Regional Organiser

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts