Heavy steering problem

User Tag List

+ Reply to Thread
Results 1 to 15 of 15

Thread: Heavy steering problem

  1. #1

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Heavy steering problem

    Owned my 1.8 for nearly 2 years now and the steering has never been like was 1.0 was which was very light compared to what I have now. I was just wondering wether this was the actual column that needs to be changed or maybe the alternator/battery. My lights on the clocks and MFD also dim when I turn my steering wheel side to side.

    Any help would be great.

    Thanks.

  2. Remove Advertisements
    Corsa-C.co.uk
    Advertisements
     

  3. #2

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bump.

    Battery is still the original one, but has been tested and charges well. Any help?

  4. #3
    Administrator
    Trusted Seller
    Pugh125k's Avatar
    Join Date
    02-12-2005
    Location
    near ludlow
    Posts
    24,174
    Mentioned
    100 Post(s)
    Tagged
    1 Thread(s)
    steering torque sensor needs adjusting maybe

    http://www.migweb.co.uk/forums/other...formation.html

  5. #4

  6. #5

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pugh125k View Post
    steering torque sensor needs adjusting maybe

    http://www.migweb.co.uk/forums/other...formation.html
    Cheers for the info, i might start by changing the battery as it will be coming up to 9 years old now. It is possible that its struggling to cope with the amount of voltage needed to power everything?

  7. #6
    Administrator
    Trusted Seller
    Pugh125k's Avatar
    Join Date
    02-12-2005
    Location
    near ludlow
    Posts
    24,174
    Mentioned
    100 Post(s)
    Tagged
    1 Thread(s)
    well if its been test and is fine :dontknow:

    could always try the above 1st as you can do that yourself for free

    then if that doesnt solve it you could buy a new battery

    also

    "My lights on the clocks and MFD also dim when I turn my steering wheel side to side

    is normal you could always upgrade the big 3 (search)

    the battery & alternator

  8. #7

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The EPS light has never come on, its not at the point where its undriveable it simply just feels heavier than it should. If i bump the tyres pressures to 36 PSi it feels like it should do.

    Ive never had problems with it sticking/jamming or being easier to steer in one direction etc so ive ruled out the torque sensor for now.

  9. #8

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Battery reads 12.4v then drops to 11.8v when HIDS are turned on.

    Is that a normal drop?

  10. #9
    Administrator
    Trusted Seller
    Pugh125k's Avatar
    Join Date
    02-12-2005
    Location
    near ludlow
    Posts
    24,174
    Mentioned
    100 Post(s)
    Tagged
    1 Thread(s)
    is this when car is on/running or off?

    it should be between 10v & 12v when car is off & at least 14v when running

    with all things on lights (inc front/rear fogs), heaters full blast/hottest setting inc rear on, cd player etc and car running it shouldnt go below 12 what does yours read?

    did you get the alternator tested as well?

  11. #10

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by pugh125k View Post
    is this when car is on/running or off?

    it should be between 10v & 12v when car is off & at least 14v when running

    with all things on lights (inc front/rear fogs), heaters full blast/hottest setting inc rear on, cd player etc and car running it shouldnt go below 12 what does yours read?

    did you get the alternator tested as well?
    That was with the car off, so seems as though the battery is fine. Above 14v when running with various thing turned on, heaters etc.

    whats the best way to test the alternator?

  12. #11
    Administrator
    Trusted Seller
    Pugh125k's Avatar
    Join Date
    02-12-2005
    Location
    near ludlow
    Posts
    24,174
    Mentioned
    100 Post(s)
    Tagged
    1 Thread(s)
    i have a battery & alternator tester £5 posted on ebay

    if not pop to a garage

  13. #12
    Administrator
    Trusted Seller
    Pugh125k's Avatar
    Join Date
    02-12-2005
    Location
    near ludlow
    Posts
    24,174
    Mentioned
    100 Post(s)
    Tagged
    1 Thread(s)

  14. #13

    Join Date
    15-04-2011
    Location
    Stoke on Trent
    Age
    22
    Posts
    865
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by JoeLloyd View Post
    That was with the car off, so seems as though the battery is fine. Above 14v when running with various thing turned on, heaters etc.

    whats the best way to test the alternator?
    battery is fine, alternator will be fine or battery would have given up, more than likely just the fact its a heavier car and so more weight over the front wheels, also wider wheels? or lower profile tyres? different brand tyres? all make a difference matey

  15. #14

    Join Date
    06-04-2011
    Age
    22
    Posts
    232
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ultrablueplus View Post
    battery is fine, alternator will be fine or battery would have given up, more than likely just the fact its a heavier car and so more weight over the front wheels, also wider wheels? or lower profile tyres? different brand tyres? all make a difference matey
    Just normal SRI's mate, 195/45/16. Its got a suspected faulty steering rack which is being changed at the weekend, will see if this makes any difference. Just wanted to rule out everything before it went it on Saturday.

    Thanks for the help.

  16. #15

    Join Date
    09-07-2012
    Location
    Sheffield
    Age
    20
    Posts
    3,006
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Faulty steering rack and you've got heavy steering?

    Should be better once that's changed

    Sent from my Galaxy SIII Mini using Tapatalk 2

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts