Vauxhall Corsa-C Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
3,362 Posts
Discussion Starter · #1 · (Edited)
Hi guys

I regularly check my oil say every month while im potting round my car. I filled up a couple of days ago on sunday, came back tonight and the oil light was on.

So obviously this threw me as the oil light has come on with 2 days of use, i proceed to check the oil again and it still says it's full to the top like it did when i added some oil in on the weekend.

Now i went back out after this, and when i drive it seems to go off but when i am waiting in traffic or stop it seems to flicker back on. Any ideas? Just a dodgy sensor or something?

Ta.
 

·
Registered
Joined
·
3,362 Posts
Discussion Starter · #6 ·
Wrong oil weight or grade? The oil light is not triggered by oil depth, it's triggered by oil pressure.
doubt it mate i have used the same proper stuff for ages.

Agreed Oil pressure switch, but filling oil right to the top mark is as bad for an engine as if its too low.
Ok i will nip to vx get a new one and swap them over, i don't fill it right to the top just to the markers on the dip stick. cheers.
 

·
Registered
Joined
·
21,904 Posts
Its a piss easy job mate - on the 1.0's and the 1.2's (unsure on 1.4's, diesels and the 1.8) it is at the front of the block, left hand side. Unplug it, take it off (spanner), put new one in, re-attach plug. Just have a rag underneath it to catch any oil otherwise it will make a mess.

takes 5 minutes :thumbs:
 

·
Registered
Joined
·
3,362 Posts
Discussion Starter · #8 ·
Its a piss easy job mate - on the 1.0's and the 1.2's (unsure on 1.4's, diesels and the 1.8) it is at the front of the block, left hand side. Unplug it, take it off (spanner), put new one in, re-attach plug. Just have a rag underneath it to catch any oil otherwise it will make a mess.

takes 5 minutes :thumbs:
cheers mate will be a saturday job :salute:
 

·
Registered
Joined
·
874 Posts
Agreed Oil pressure switch, but filling oil right to the top mark is as bad for an engine as if its too low.
mine is filled to the top of the dipstick, my mechanic filled it to there in april and had no problems. i have not had to top it up yet. i even managed to find picture on google of corsa engine lol
 

·
Registered
Joined
·
3,362 Posts
Discussion Starter · #10 ·
Right i spoke to my dad and apparently we used a different grade of oil instead of the standard 40/100. Apparently the one we used last time was thicker which could be causing the problem setting the sensor off.

do i flush the enigne and start all over again or wait for the current oil to go and fill it up with 40/100?
 

·
Registered
Joined
·
1,361 Posts
You want 10/40w

mine is filled to the top of the dipstick, my mechanic filled it to there in april and had no problems. i have not had to top it up yet. i even managed to find picture on google of corsa engine lol
Too high should be on the top rib of the wide bit
 
1 - 14 of 14 Posts
Top