Vauxhall Corsa-C Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
455 Posts
Discussion Starter · #1 ·
hi guys, wen i switch my dipped beam on in my angels, the drivers side doesnt work and there is a horrible smell of burning plastic? Everything else on the unit work fine, just the dipped beam. Any ideas wat this could be?
 

·
Banned
Joined
·
22,984 Posts
I think burning plastic may be your problem.
 

·
Registered
Joined
·
493 Posts
I think burning plastic may be your problem.
:lol:

hi guys, wen i switch my dipped beam on in my angels, the drivers side doesnt work and there is a horrible smell of burning plastic? Everything else on the unit work fine, just the dipped beam. Any ideas wat this could be?
bulbs are sat in there holder right? the connection block on the bulbs are ok (not burning)?
 

·
Registered
Joined
·
455 Posts
Discussion Starter · #6 ·
just been out to have a look at them mate, no smell, no sign of melting on any wires or connectors? Dont no what was causing the smell?? Cheers anyway though guys!
 

·
Registered
Joined
·
493 Posts
just been out to have a look at them mate, no smell, no sign of melting on any wires or connectors? Dont no what was causing the smell?? Cheers anyway though guys!
if its just when you turn your lights on, could try taking the bulb out still and connect it up outside the headlight see if you can smell burning. obviously find something to hold the bulb so you dont burn youself and not toucking the bulb end either. just something i would try.

not at this time though its abit late :D
 

·
Registered
Joined
·
455 Posts
Discussion Starter · #8 ·
yeah i think ill try it mate, wen its day like so i can see what im doing! Cheers for the advice tho fella
 
1 - 9 of 9 Posts
Top