Vauxhall Corsa-C Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi Guys,

So I have a 55 reg 1.3CDTI Corsa.

Yesterday the mileage digital dial starts flashing and the the rev and speedo stops working and then the power steering stops. I stop the engine and start again and all is fine and then the flashing starts again then everything dies. The engine and car still run fine, the radio doesn't stop and power seems to be ok. I have noticed that when left idle and the flashing begins the car gives a tiny rev insync with the flashing.

I have taken the clocks and and check the multi plug is secured, looked at the fuse which seems to be fine.

Any other suggestions?

As its a CDTI I can't do the pedal test to check any codes.

I have recently moved to Tunbridge Wells, Kent so don't know any local mechanics.

Thanks

James
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I tried switching the fuse with another in my fuse box just to check and didn't help. I'll have another look tomorrow.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
OK had a look this morning. What I've discovered is very bizarre.

If I run the car without any lights, stereo, heater on the dials and steering fail when idle.

If I switch the heater on full blast I can rev nearly to 1500 before before it dials and steering fail.

If have the heater full blast and lights on it can go over 1500 revs before it dials and steering fail.

If I have everything on including the fog lights the car runs perfect again.

Now I had an mot recently and one of the advisors was not enough power going to front light. Checked this yesterday and seems like the light was not insert probably more worrying was the case covering the lights was off. Now would getting this wet cause this electronic problem? Or is it something else?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
It was the driver side front light. Took the bulb out etc but problem didn't seem linked. Would something like this have an error code?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Out tonight and saw a cog near my alternator moves slightly and when it does the dash goes off.
 

·
Registered
Joined
·
1 Posts
Out tonight and saw a cog near my alternator moves slightly and when it does the dash goes off.
It's been six years since you left this comment about a problem you were having with a Corsa power steering and the dash clocks, but did you get it sorted. In this last comment you said ''there was a cog near the alternator which if moved made the dash go off'' What was the ''cog''
I would be very grateful to find an answer to this problem, my daughters Corsa is doing the same thing, with no fault codes.
 

·
Registered
Joined
·
2,498 Posts
Welcome to CCUK, Davyf, but please start a new thread and write up your daughter's C (year, engine) and what the problems are to get an answer from current members. Everybody on this thread has moved on from C ownership now and >1yr threads get locked by the mods.
 
1 - 11 of 11 Posts
Top