Vauxhall Corsa-C Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Vauxhall corsa 1.2 05 plate sxi.turns over but wont start nolights on left sid of the dash .but lights on right side working also no wipers working .help please..
 

·
Registered
Joined
·
2,091 Posts
Sounds like it could be the loose connection at the back of the instruments, which can immobilise the car. Try giving the plexi panel a good shove without cracking it. If no joy, you might have to take out the clocks unit and make sure the (single) connector is firmly in. There are YouTube videos on taking the clocks out and also tutorials here.

Any problems finding vids or tutorials, post again here and I'll link some up.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Vauxhall corsa 1.2 05 plate sxi.turns over but wont start nolights on left sid of the dash .but lights on right side working also no wipers working .help please..
Vauxhall corsa 1.2 05 plate sxi.turns over but wont start nolights on left sid of the dash .but lights on right side working also no wipers working .help please..
Sounds like it could be the loose connection at the back of the instruments, which can immobilise the car. Try giving the plexi panel a good shove without cracking it. If no joy, you might have to take out the clocks unit and make sure the (single) connector is firmly in. There are YouTube videos on taking the clocks out and also tutorials here.

Any problems finding vids or tutorials, post again here and I'll link some up.
Some linkk would help if possable big thanks..
 

·
Registered
Joined
·
2,091 Posts
You might not have to do this - a mild thump on the front might work - but this is a decent video on getting the cluster out. At 6:58, you can see the connector round the back. This is what you need to make sure is clean and firmly hooked up.
 
1 - 5 of 5 Posts
Top