Vauxhall Corsa-C Forum banner

41 - 47 of 47 Posts

·
Super Moderator
Joined
·
8,333 Posts
ok, so i think the heater matrix pipes you have cut will have had grooves in for the clip to seat into to hold the black rubber pipes onto them, sounds like that bit has been cut off, so ya gonna need a new matrix, i have never taken mine off, but i can see how they are connected.

just show us some pics of the 2 black rubber pipe ends, and the 2 matrix pipes you cut, have ya still got the ends you cut off.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #43
Well, it looks like I've fixed it!
After many many failed attempts to stop the coolant dripping I've finally cracked it.

I'll take some pictures of the job, but basically I bought some food grade PVC hose with an internal diameter of 19mm, which I slipped over the ends of the pipes, bridging the gap from where I had removed material.

I gasketted the connection using hylomar blue, and secured it all with 19/29mm jubilee clips.

I had to get an old matrix from a corsa down the scrap yard. I flushed it out and despite being ancent, it was clean and functioning correctly.
I also took the heater matrix pipes completely out of the scrapped corsa, which I used to complete the job on my car.

This will all be waaaaay easier to explain with some photos....
 

·
Registered
Joined
·
1,689 Posts
Always glad to see a resolved problem, so the pics could well be useful to someone in the future. Glad you're back to a heated car in time for the 3rd storm in as many weeks.
 
41 - 47 of 47 Posts
Top