Vauxhall Corsa-C Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
31 Posts
Seems a lot of cases are different.

I've no comms now with ecu or immobiliser. Haven't got around for testing for power at the ecu yet, but I do not believe that is the problem. I think mine is a broken CAN wire somewhere.
It's just getting the time to look at it.
 

·
Registered
Joined
·
31 Posts
Had a look this morning. All ecu power and grounds seemed fine, wiring from ecu to immobiliser seemed fine, CAN at the ecu scoped out a nice clean signal...so before pulling apart the BCM enclosure, decided to try pulling the clocks out.
Did this, everything looked ok. Unplugged the connector, gave it a little clean, connected it back up and all seems to be restored to normal.
Have full comms with all modules and ecu and it's starting and running fine ( well only tried once, and haven't driven it yet ).
But it appears to be back to normal.

I always did have good comms with the dash though which is weird, only lost comms with engine ecu and immobiliser.

But all seems fine for now.
 

·
Registered
Joined
·
31 Posts
Yes, the instrument cluster. just blew them out with an airline. But it was clean anyway, no signs of corrosion or anything and was securely fastened.

makes little sense.
 

·
Registered
Joined
·
31 Posts
******...knew it seemed too unlikely to be true.

Went back out to start it and it's flashing again lol, no amount of messing with the clocks makes a difference, CAN signal at the clocks is good and clean.

Back to no comms with ecu and immobiliser. Although strangely the headlights also seemed to be messing about when I was working at it....perhaps there is a BCM issue of some sort causing it.
Will try another BCM tomorrow if I get a chance, although that may be futile unless it restores comms with the Immob and ECU.
 

·
Registered
Joined
·
31 Posts
well, it was the immobiliser ring at the barrel after all.

Some help/advice from liviu2004 and, I bought a new one and programmed it, and all is well now.

The water ingress into BCM enclosure whilst a problem, seems to have been a massive red herring with the two problems appearing at once.
 
21 - 31 of 31 Posts
Top