Vauxhall Corsa-C Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi,

all my left side indicators have stoped working, inside the indicator blinks fast and outside nothing. I've looked at my fuse box and checked both fuses 3 & 11 and both are fine, ti've pulled out most of the fuses and made sure their in properly. The manual doesn't say anything about relays or indicators so i need your help people....


Thanks
 

·
Registered
Joined
·
4,524 Posts
If its flashing fast inside a bulbs gone outside.

Try your hazard lights do both sides flash is 1 bulb not flashing?

Try checking all bulbs
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Went to vauxhall and they said it was a modulator or something.. Apparently it goes in corsa's from time to time. Anway gonna get it done tomorrow in another vauxhall garage, just gotta navigate down there with no left indicators....other cars on the road are gonna love me
 

·
Registered
Joined
·
4,524 Posts
Went to vauxhall and they said it was a modulator or something.. Apparently it goes in corsa's from time to time. Anway gonna get it done tomorrow in another vauxhall garage, just gotta navigate down there with no left indicators....other cars on the road are gonna love me
Read the highway code, there is a hand signal you have to use to turn left :)
 

·
Registered
Joined
·
131 Posts
Went to vauxhall and they said it was a modulator or something.. Apparently it goes in corsa's from time to time. Anway gonna get it done tomorrow in another vauxhall garage, just gotta navigate down there with no left indicators....other cars on the road are gonna love me
What did they quote you? Same thing happened to mine..
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top