Vauxhall Corsa-C Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi.

This morning, I took off a trailer from my towbar, while the hazard lights were flashing. However, I accidently pulled the trailer's wires off the trailer plug (easy fix), but now, neither the turn signal lights or the hazards lights flash at all. All I get is the the quick flashing and clicking on the dashboard. I suspect I have shorted out a fuse or relay, but I am unsure which. Again, absolutely no flashing, so would that be a fuse? If yes, where is it located?

Kind regards.
 

·
Registered
Joined
·
79 Posts
Probably the indicator relay. That's situated in the BCM which is the black box next to the battery. The relay is at the front of the BCM - it's big and yellow!
(this info is based on how it's laid out in my corsa c, so may be different in yours)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Probably the indicator relay. That's situated in the BCM which is the black box next to the battery. The relay is at the front of the BCM - it's big and yellow!
(this info is based on how it's laid out in my corsa c, so may be different in yours)
Thanks for your reply! I have located the indicator relay, which in my case (2006 Z12XEP) are two smaller yellow relays, one for each side. They both click according to which side I turn the flashers on. I have also tried switching them around, but without any results.

Does the clicking mean they are still functional or should they be replaced?
 

·
Registered
Joined
·
79 Posts
Honestly I don't really know!
My indicators went kaput a few days ago - fast flashing and clicking inside the car on the dash, but no lights outside.
Mine was the relay. Cost £27.
 
1 - 5 of 5 Posts
Top