Vauxhall Corsa-C Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys I own a 2006 automatic vauxhaul corsa my radio has recently stopped working I’ve replaced the fuse for the radio but does anyone know the main fuse number or what else this could be I don’t own a manual and can’t find any info anywhere
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
That’s brill Thankyou I will take a look tommorow It was working and then all of a sudden I hit a bump and my radio said miswiring reconnect and then it just completely stopped working I replaced the fuse in the radio itself as it was blown I have checked the wires but can’t see no problem with the wiring no disconnected ones from the bump or anything I will check the main fuse tommorow but if it’s not the fuse what else can I do to diagnose the problem not sure if it helps but I don’t have the original radio the previous owner removed it and installed a jvc updated one
 

·
Registered
Joined
·
199 Posts
I very well remember instruction manual from my first car - before replacing a blown fuse, find a reason why it blew.

There is something wrong with your radio if the fuse on the radio itself was blown. What it is, nobody knows.

Which year is the car?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I very well remember instruction manual from my first car - before replacing a blown fuse, find a reason why it blew.

There is something wrong with your radio if the fuse on the radio itself was blown. What it is, nobody knows.

Which year is the car?
The year is 2006
 

·
Registered
Joined
·
199 Posts
That was just to clarify if it has another wire from the ignition to "wake up" the radio, 2006. does not have that wire. Just red (+) and brown (-).
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
That was just to clarify if it has another wire from the ignition to "wake up" the radio, 2006. does not have that wire. Just red (+) and brown (-).
Thankyou for getting back to me so what are my next steps all’s I know Is it said miswiring on my radio please reconnect then stopped working I replaced its fuse then tried pushing the wires in thinking maybe there loose and then the disc tray started working and making its original sound but that’s it no display on the radio no music no nothing I check my fuses under the hood f12 is not blown so I cannot find the problem I’m edgin towards maybe it’s the positive wire or maybe the radio itself has broke
 

·
Registered
Joined
·
199 Posts
Sounds like a busted radio... If you think the wiring in the car is bad than you can simply take the radio out together with its adapter and connect it directly to + and - of your battery with two pieces of wire and some dexterity :p. Of course, take care not to misplace positive and negative, that would probably be the last nail in its coffin.
 
1 - 8 of 8 Posts
Top