Vauxhall Corsa-C Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
My Corsa with z12xep engine started leaking oil one day just like a little drip and I was never bothered about fixing it. but recently it's started pissing out, within a half and hours drive the oil has gone from top of the dipstick to complete off it. It's dripping from the bottom left hand bolt of the exhaust manifold just behind it. it's just a constant drip. I'm presuming it's running from somewhere else but for the life of me can't see where it's coming from.

Any ideas of where it could be leaking from or how to stop it would be very much appreciated , cheers
 

·
Super Moderator
Joined
·
8,337 Posts
oil pressure switch, cam cover? have ya got a pic of it, clean the oil of from where ya think its leaking, then start it up to see if you can spot a leak.
 

·
Wales Organiser
Joined
·
50,214 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #5
It doesn't look wet at all round the oil pressure switch it's coming from like underneath routes the exhuast manifold like a constant drip???

Never thot I should have took a video of it dripping , I can't now as I have took the rocker cover off to see if it was like running from there and down
 

·
Registered
Joined
·
1,814 Posts
Well it could be the rocker cover gasket, not coming out the oil cap or dipstick hole i suppose....might also be worth looking to see if the breathers are blocked, especially the vacuum pipe to the inlet manifold, if that system gets blocked it can throw oil out everywhere,,,,think you might have to wash it down and have a careful look....might even be the head gasket, it's no where near the oil filter i suppose or turbo......Fred.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #7
Re sealed the rocker cover. took out the bolt that the oil was dripping from and it was soaked with oil , inside the bolt whole was also full of oil. Any chance that a bolt might have poked right through into the head?
 

·
Registered
Joined
·
2,113 Posts
If it's under the manifold then I'd have said oil filter or dipstick area for checking. It the sump gasket has gone walkabout.
 

·
Registered
Joined
·
2,113 Posts
If you can't see any obvious leak form pressure switch or cam cover then there's not much in between. Only the head gasket, and I'm not sure where the oil feed to the head is on that engine. Or filter feed leaking and spraying up on the exhaust.

Should be easy to find, wash it all off with Gunk, then rinse with water. Start the engine and see where it leaks from.
 

·
Registered
Joined
·
2 Posts
It's leaking from well above the sump can actually watch a constant drip of oil from exhaust manifold

Does it look like this (this is a Z14 XEP but suspect its the same position?)
35405


35406



Trouble is, when the car is running it burns behind the exhaust, when its not running, it simply seems to seep and then stop. There's no oil on the cardboard although I did previously change the oil pressure switch as that was leaking like crazy- and I'm suspecting this leak and the pressure switch failing is linked but because of this stupid oil filter housing design/position I can't quite tell where its coming from.

Anyone know if this is a common problem and what me and the OP need to look out for?
 

·
Administrator, Trusted Seller
Joined
·
605,307 Posts
Does it look like this (this is a Z14 XEP but suspect its the same position?) View attachment 35405

View attachment 35406


Trouble is, when the car is running it burns behind the exhaust, when its not running, it simply seems to seep and then stop. There's no oil on the cardboard although I did previously change the oil pressure switch as that was leaking like crazy- and I'm suspecting this leak and the pressure switch failing is linked but because of this stupid oil filter housing design/position I can't quite tell where its coming from.

Anyone know if this is a common problem and what me and the OP need to look out for?
please look at the thread date before posting, i sure hope the op has sorted the problem out since this was back in 2016
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top