Vauxhall Corsa-C Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi. Bought 1.4 Auto with dead speedo for daughter, thinking I could fix it. Ha! Have pulled clocks, checked sender connection on auto box, swapped orange relay to no avail. After a few weeks sitting I charged battery and cleaned damp leaves from around BCM: it then worked for the next short trip but not again. Pulled glovebox and prodded wiring, but nothing. Am about to start messing with BCM. Any info on which pins and wires I should focus on or other advice would be appreciated. Car runs normally, taught her to drive it with phone app speedo, but she won't take it over until "legal".
 

·
Registered
Joined
·
1,298 Posts
The Speedo gets its signal from the nearside front wheel, at least on all the manual transmission's, can't see they would change that just for auto's.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks. This is an Australian spec car: no ABS. If I pull VSS it goes into limp home mode. Did buy a part from ebay uk as initial response to 500 code, but it wasn't the same plug. Guess since car runs okay the VSS must be working and problem further up the line.
 

·
Registered
Joined
·
1,298 Posts
The speed sensor on the gearbox sounds more like it's part of the gearbox control system. European cars with no abs still use the nearside front wheel for road speed and fault/disconnection doesn't cause any sort of limp mode.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Sorry for delay, no notification. Yes, quite right, there is a near front wheel sensor. Apologies, will investigate if it is the problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Well, cable from wheel sensor has been adrift from its clip and rubbing on tyre to the point where copper wire within insulation looks broken. Question: is there just one, in which case I can patch it, or is it coaxial? (In which case it will be difficult.)
Plug on firewall looks intimidating, any tips ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Success! Pair of wires inside sensor cable and easy to repair. Thanks to Mr Drew for redirecting my efforts.
 
1 - 9 of 9 Posts
Top