Vauxhall Corsa-C Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
Hi, there people. I just installed my kenwood 7024 HU today. I also purchased Autoleads PC9-706 steering stalk adaptor loom.

This is the correct accessory for corsa 2000+ model.

It does not seem to connect properly to the ISO block on the car!? There are three connections on the ISO block, however through this adaptor it is only possible to connect one. Therefore the steering controls work but there is no sound (Unable to connect the speaker bus adaptor while the other adaptor is connected).

Anyone else understand what i'm talkin about?

The only way that i can see around this is to split up the ISO block on the car, not realy a wise move though.

cheers j
 

·
Registered
Joined
·
1,551 Posts
Sweeny said:
hum i didnt bother connecting them up 2 b honnest, :(

so my stalk controls only work wid da radio n not da cd :)
I had to cut the plastic so that it could fit on that blue connector! Otherwise its too big!
 

·
Registered
Joined
·
1,060 Posts
here mate, i bought the M7024 for my Zr and the ****er is tratling so im gettin a replace ment.

let me know if urs does the same.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
Hey folks i got it sorted, steering controls working great now!

They even have the capabilites to deliver more functions.

To solve the problem i had to sand about 1mm of the plastic back on the autoleads adapter so that it would fit into the ISO block on the car.

Luckily no problems with the HU scott, Although i still havent worked through half the features it has.

Crackin HU though really pleased with it.

j
 
1 - 5 of 5 Posts
Top